2019-07-18 15:41:56

静态路由 免费编辑 添加义项名

B 添加义项
?
义项指多义词的不同概念,如李娜的义项:网球运动员、歌手等;非诚勿扰的义项:冯小刚执导电影、江苏卫视交友节目等。 查看详细规范>>
所属类别 :
电子技术
电子技术
编辑分类

静态路由是指由用户或网络管理员手工配置的路由信息。当网络的拓扑结构或链路的状态发生变化时,网络管理员需要手工去修改路由表中相关的静态路由信息。静态路由信息在缺省情况下是私有的,不会传递给其他的路由器。当然,网管员也可以通过对路由器进行设置使之成为共享的。静态路由一般适用于比较简单的网络环境,在这样的环境中,网络管理员易于清楚地了解网络的拓扑结构,便于设置正确的路由信息。

在一个支持DDR(Dial-on-Demand Routing)的网络中,拨号链路只在需要时才拨通,因此不能为动态路由信息表提供路由信息的变更情况。在这种情况下,网络也适合使用静态路由。

基本信息

  • 中文名

    静态路由

  • 外文名

    Static routing

  • 使    用

    网络

  • 解    释

    网络管理员手工配置的路由信息

折叠 编辑本段 简介

静态路由由管理员亲自手动配置 。

静态路由静态路由

动态路由用在大型的网络,几百台甚至上千台路由器 。

静态路由对路由器的路由选择进行控制,节省了网络带宽,减少了额外开支。

静态路由允许指定受限制部分的广播内容,可出于安全而隐藏网络的一部分。

动态路由的路由器间发送定时的路由更新信息,根据新信息计算新的最佳路由。

折叠 编辑本段 优点

使用静态路由的另一个好处是网络安全保密性高。动态路由因为需要路由器之间频繁地交换各自的路由表,而对路由表的分析可以揭示网络的拓扑结构网络地址等信息。因此,网络出于安全方面的考虑也可以采用静态路由。不占用网络带宽,因为静态路由不会产生更新流量。

折叠 编辑本段 缺点

大型和复杂的网络环境通常不宜采用静态路由。一方面,网络管理员难以全面地了解整个网络的拓扑结构;另一方面,当网络的拓扑结构和链路状态发生变化时,路由器中的静态路由信息需要大范围地调整,这一工作的难度和复杂程度非常高。

折叠 编辑本段 配置命令

(以右图为例)

静态路由的配置有两种方法:带下一跳路由器的静态路由,和带送出接口的静态路由

router(config)#hostname A (更改路由器主机名)

A(config)#interface f0/0 (进入接口f0/0)

A(config-if)#ip address 192.168.1.1 255.255.255.0 (设置接口ip地址和子网掩码

A(config-if)#no shutdown (启用接口)

A(config)#interface f0/1

A(config-if)#ip address 192.168.2.1 255.255.255.0

A(config-if)#no shutdown

×××以下二选一:

A(config)#ip route 192.168.3.0 255.255.255.0 f0/1(目标网段ip地址 目标子网掩码送出接口(路由器A))

或者

A(config)#ip route 192.168.3.0 255.255.255.0 192.168.2.2 (目标网段ip地址 目标子网掩码下一路由器接口ip地址)

×××

router(config)#hostname B

B(config)#interface f0/0

B(config-if)#ip address 192.168.3.1 255.255.255.0

B(config-if)#no shutdown

B(config)#interface f0/1

B(config-if)#ip address 192.168.2.2 255.255.255.0

B(config-if)#no shutdown

×××以下二选一:

B(config)#ip route 192.168.1.0 255.255.255.0 192.168.2.1

或者:

B(config)#ip route 192.168.1.0 255.255.255.0 f0/1(目标网段ip地址 目标子网掩码送出接口(路由器B))

×××

注1:此网络链路为以太网链路,如果是串行链路,送出接口也就是本地路由器串行接口

简明解释:ip route 192.168.3.0 255.255.255.0 192.168.2.2

这句话的意思是:在HOSTA上,路由器见到目的网段为192.168.3.0的数据包,就将数据包发送到192.168.2.2上

注2:ip route 指向一个就可,如果两个都配了,就是说将这个数据包从发fa0/1出去,而另一个说数据包发到这个ip(例如192.168.2.2)。两个重复。一般我们设置为指向IP。

折叠 编辑本段 常见问题

1)为什么要有默认路由

路由得查看路由表而决定怎么转发数据包,用静态路由一个个的配置,繁琐易错。如果路由器有个邻居知道怎么前往所有的目的地,可以把路由表匹配的任务交给它,省了很多事。

例,网关会知道所有的路由,如果一个路由器连接到网关,就可以配置默认路由,把所有的数据包都转发到网关。

2)为什么默认路由是0.0.0.0

匹配IP地址时,0表示wildcard, 任何值都可以。所以0.0.0.0和任何目的地址匹配都会成功,造成默认路由要求的效果。

折叠 编辑本段 配置路由

配置路由器r1端口:

Router>en

Router#config // 进入配置模式

Configuring from terminal, memory, or network [terminal]? t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname r1//更改主机名为r1

r1(config)#int f0/0 //配置端口f0/0

r1(config-if)#ip add 192.168.1.1 255.255.255.0//设置端口ip

r1(config-if)#no shut//打开端口

%LINK-5-CHANGED: Interface FastEthernet1/0, changed state to up

r1(config-if)#

%SYS-5-CONFIG_I: Configured from console by console

r1(config)#int f1/0//配置端口f1/0

r1(config-if)#ip add 192.168.2.1 255.255.255.0//设置端口ip

r1(config-if)#no shut//打开端口

%LINK-5-CHANGED: Interface FastEthernet1/0, changed state to up

配置路由器r2端口

Router(config)#hostname R2//更改主机名为R2

R2(config)#int f0/0 //配置端口f0/0

R2(config-if)#ip add 192.168.2.2 255.255.255.0//设置端口ip

R2config-if)#no shut//打开端口

R2(config)#int f0/0 //配置端口f1/0

R2(config-if)#ip add 192.168.3.1 255.255.255.0//设置端口ip

R2(config-if)#no shut//打开端口

&n 

R2(config-if)#ip add 192.168.3.1 255.255.255.0//设置端口ip

R2(config-if)#no shut//打开端口

配置路由器R3端口[1]

Router(config)#hostname R3//更改主机名为R3

R3(config)#int f0/0 //配置端口f0/0

R3(config-if)#ip add 192.168.3.2 255.255.255.0//设置端口ip

R3config-if)#no shut//打开端口

R3(config)#int f0/0 //配置端口f1/0

R3(config-if)#ip add 192.168.4.1 255.255.255.0//设置端口ip

R3config-if)#no shut//打开端口

阅读全文

热点资讯